<!DOCTYPE html><html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en" itemid="https://frontline.thehindu.com/news/inside-myanmar-anti-junta-rebel-forces/article66053268.ece" itemscope itemtype="http://schema.org/NewsArticle"><head><title>
Inside Myanmar’s anti-junta rebel forces - Frontline
</title><meta charset="utf-8"><meta http-equiv="X-UA-Compatible" content="IE=edge"><meta name="viewport" content="width=device-width, initial-scale=1"><meta name="title" content="Inside Myanmar’s anti-junta rebel forces" /><meta name="description" content="Ethnic rebels wage jungle warfare against the military dictatorship in hopes of restoring democracy." /><meta name="publish-date" content="2022-10-25T17:47:49+05:30" /><meta name="created-date" content="2022-10-25T17:47:49+05:30" /><meta name="modified-date" content="2022-10-25T17:47:51+05:30" /><meta property="article:published_time" content="2022-10-25T12:17:49.000Z" /><meta property="article:modified_time" content="2022-10-25T12:17:51Z" /><meta name="cXenseParse:articleid" content="66053268" /><meta name="cXenseParse:thg-articleid" content="66053268" /><meta property="al:android:url" content="https://frontline.thehindu.com/news/inside-myanmar-anti-junta-rebel-forces/article66053268.ece" /><meta property="article:section" content="News" /><meta property="article:tag" content="Inside Myanmar’s anti-junta rebel forces" /><meta property="article:tag" content="myanmar" /><meta property="article:tag" content="myanmar junta" /><meta property="article:tag" content="aung san suu kyi" /><meta property="article:tag" content="national unity government" /><meta property="article:tag" content="democracy" /><meta property="article:tag" content="military dictatorship" /><meta property="article:tag" content="karen state" /><meta property="article:author" content="Deutsche Welle" /><meta name="twitter:creator" content="Deutsche Welle"><meta name="keywords" content="Inside Myanmar’s anti-junta rebel forces,myanmar,myanmar junta,aung san suu kyi,national unity government,democracy,military dictatorship,karen state" /><meta name="news_keywords" content="Inside Myanmar’s anti-junta rebel forces,myanmar,myanmar junta,aung san suu kyi,national unity government,democracy,military dictatorship,karen state" /><meta name="robots" content="index, follow" /><meta name="robots" content="max-image-preview:large"><meta name="atdlayout" content="articlepage" /><meta name="twitter:title" content="Inside Myanmar’s anti-junta rebel forces"><meta name="twitter:description" content="Ethnic rebels wage jungle warfare against the military dictatorship in hopes of restoring democracy."><meta name="twitter:image" content="https://fl-i.thgim.com/public/incoming/o7ti32/article66053254.ece/alternates/FREE_1200/myanmar%20anti%20junta.jpg"><meta property="og:title" content="Inside Myanmar’s anti-junta rebel forces" /><meta property="og:description" content="Ethnic rebels wage jungle warfare against the military dictatorship in hopes of restoring democracy." /><meta property="og:image" content="https://fl-i.thgim.com/public/incoming/o7ti32/article66053254.ece/alternates/FREE_1200/myanmar%20anti%20junta.jpg" /><meta property="og:url" content="https://frontline.thehindu.com/news/inside-myanmar-anti-junta-rebel-forces/article66053268.ece" /><meta property="al:android:url" content="https://frontline.thehindu.com/news/inside-myanmar-anti-junta-rebel-forces/article66053268.ece" /><meta property="og:type" content="article" /><meta name="ahrefs-site-verification" content="6df5b97abf2ea60f2d4123265496b92b4faa009ceff5444e0b8482ebddd508d6" /><meta name="google-site-verification" content="jlS-WsOVad-iw4X4xO0EJnHuzr3pK7WqXt3oCy7jpXI" /><meta name="msvalidate:01" content="A0ACE607D11E08C87CE9AEB4F809133F" /><meta name="twitter:domain" content="frontline.in" /><meta name="twitter:site" content="@frontline_india" /><meta property="fb:app_id" content="304083423879211" /><link rel="shortcut icon" type="image/x-icon" href="https://frontline.thehindu.com/favicon.ico" /><link rel="icon" type="image/ico" href="https://frontline.thehindu.com/favicon.ico" /><link rel="apple-touch-icon" href="https://frontline.thehindu.com/apple-touch-icon.png" /><link rel="apple-touch-icon-precomposed" href="https://frontline.thehindu.com/apple-touch-icon-precomposed.png" /><link rel="canonical" href="https://frontline.thehindu.com/news/inside-myanmar-anti-junta-rebel-forces/article66053268.ece" /><link rel="amphtml" href="https://frontline.thehindu.com/news/inside-myanmar-anti-junta-rebel-forces/article66053268.ece/amp/"><link rel="preload" href="https://fonts.gstatic.com/s/merriweathersans/v13/2-cO9IRs1JiJN1FRAMjTN5zd9vgsFF_5asQTb6hZ2JKZou4ViesH.woff2" as="font" type="font/woff2" crossorigin><link rel="preload" href="https://fonts.gstatic.com/s/bitter/v16/raxhHiqOu8IVPmnRc6SY1KXhnF_Y8fbfOLjOXQ.woff2" as="font" type="font/woff2" crossorigin><link rel="preload" href="https://fonts.gstatic.com/s/ptsanscaption/v13/0FlMVP6Hrxmt7-fsUFhlFXNIlpcaeg_x.woff2" as="font" type="font/woff2" crossorigin><link rel="preload" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css" as="font" type="font/woff2" crossorigin><link href="https://www.googletagmanager.com" rel="dns-prefetch"><link href="https://www.googletagmanager.com" rel="preconnect"><link href="https://cdn.tinypass.com" rel="dns-prefetch"><link href="https://cdn.tinypass.com" rel="preconnect"><link href="https://cdn.cxense.com" rel="dns-prefetch"><link href="https://cdn.cxense.com" rel="preconnect"><link href="https://fonts.googleapis.com" rel="dns-prefetch"><link href="https://fonts.googleapis.com" rel="preconnect"><link href="https://experience.tinypass.com" rel="dns-prefetch"><link href="https://experience.tinypass.com" rel="preconnect"><link href="https://consent.trustarc.com" rel="dns-prefetch"><link href="https://consent.trustarc.com" rel="preconnect"><link href="https://buy.tinypass.com" rel="dns-prefetch"><link href="https://buy.tinypass.com" rel="preconnect"><link href="https://trustarc.mgr.consensu.org" rel="dns-prefetch"><link href="https://trustarc.mgr.consensu.org" rel="preconnect"><link href="https://connect.facebook.net" rel="dns-prefetch"><link href="https://connect.facebook.net" rel="preconnect"><script>
var dataLayer = window.dataLayer || [];
	dataLayer.push({
		'pageDetails' : {
			'pageType' : 'article' ,
			'headline' : 'Inside Myanmar’s anti-junta rebel forces' ,
			'articleId' : '66053268' ,
			'articleType' : 'free',
			'authorName' : 'Deutsche Welle' ,
			'publishDate' : '2022-10-25' ,
			'publishTime' : '17:47' ,
			'hoursSincePublished' : '0',
			'contentCategory' : 'news','featureType' : 'storyline Commentary' ,
			'articleTags' : '' // when available
		} });

</script><style>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</style><link rel="preload" type="text/css" href="https://frontline.thehindu.com/theme/css/fl-online.min.css?ver=1666353526" as="style" /><link rel="stylesheet" type="text/css" href="https://frontline.thehindu.com/theme/css/fl-online.min.css?ver=1666353526" as="style" /><link href="https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css" rel="stylesheet"><link href="https://frontline.thehindu.com/theme/fonts/fl-online/LoraFont/stylesheet.css?ver=1666353249" rel="preload" /><link href="https://frontline.thehindu.com/theme/fonts/fl-online/LoraFont/stylesheet.css?ver=1666353249" rel="stylesheet" /><link href="https://frontline.thehindu.com/theme/fonts/fl-online/HindMaduraiFont/stylesheet.css?ver=1666353249" rel="preload" /><link href="https://frontline.thehindu.com/theme/fonts/fl-online/HindMaduraiFont/stylesheet.css?ver=1666353249" rel="stylesheet" /><link rel="preload" href="https://frontline.thehindu.com/theme/css/fl-online/print.min.css?ver=1666353688" media="none" onload="if(media!='print')media='print'"><link rel="stylesheet" href="https://frontline.thehindu.com/theme/css/fl-online/print.min.css?ver=1666353688" media="none" onload="if(media!='print')media='print'"><noscript><link rel="stylesheet" href="https://frontline.thehindu.com/theme/css/fl-online/print.min.css?ver=1666353688"  media="print"></noscript><script type="text/javascript">
(function(w,d,s,r,k,h,m){
    if(w.performance && w.performance.timing && w.performance.navigation) {
        w[r] = w[r] || function(){(w[r].q = w[r].q || []).push(arguments)};
        (w[r].q = w[r].q || []).push(['trackConsoleEvents',true]);
        (w[r].q = w[r].q || []).push(['addBreadCrumbs',"setTimeoutFunction"]);
        tp = window["tp"] || [];
        tp.push(["init", function () {
			if (tp.user.isUserValid()) {
          	  (w[r].q = w[r].q || []).push(['userId',tp.pianoId.getUser().email]);
			}
        }]);
        h=d.createElement('script');h.async=true;h.setAttribute('src',s+k);
        d.getElementsByTagName('head')[0].appendChild(h);
        (m = window.onerror),(window.onerror = function (b, c, d, f, g) {
        m && m(b, c, d, f, g),g || (g = new Error(b)),(w[r].q = w[r].q || []).push(["captureException",g]);})
    }
})(window,document,'//static.site24x7rum.in/beacon/site24x7rum-min.js?appKey=','s247r','53c4badd3a20139b36f250cd54fc9004');
</script><script data-cfasync="false">
if(!(window.fetch&&window.Promise&&[].includes&&Object.assign&&window.Map)){
	document.write('<script src="https://cdn.polyfill.io/v2/polyfill.min.js?features=default,fetch"></scr'+'ipt>');
}
</script><script type="text/javascript" data-cfasync="false">
(()=>{const t="__tcfapiLocator",e="__tcfapiTrustarc",n=[];let s,a=window;for(;a;){try{if(a.frames[t]){s=a;break}}catch(t){}if(a===window.top)break;a=a.parent}s||(function n(){const s=a.document,o=!!a.frames[t];if(!o)if(s.body){const n=s.createElement("iframe");n.name=t,n.style.display="none",n.id=e,n.src="https://trustarc.mgr.consensu.org/asset/cmpcookie.v2.html",s.body.appendChild(n)}else setTimeout(n,5);return!o}(),a.__tcfapi=function(...t){let e;if(!t.length)return n;if("setGdprApplies"===t[0])t.length>3&&2===parseInt(t[1],10)&&"boolean"==typeof t[3]&&(e=t[3],"function"==typeof t[2]&&t[2]("set",!0));else if("ping"===t[0]){const n={gdprApplies:e,cmpLoaded:!1,cmpStatus:"stubCMP",apiVersion:"2.0"};"function"==typeof t[2]&&t[2](n,!0)}else n.push(t)},a.addEventListener("message",function(t){const e="string"==typeof t.data;let n={};try{n=e?JSON.parse(t.data):t.data}catch(t){}const s=n.__tcfapiCall;s&&window.__tcfapi(s.command,s.version,function(n,a){let o={__tcfapiReturn:{returnValue:n,success:a,callId:s.callId}};e&&(o=JSON.stringify(o)),t.source.postMessage(o,"*")},s.parameter)},!1))})();
</script><script type="text/javascript" data-cfasync="false">
var thgCookieConsent = new Promise(function(resolve, reject) {
    let script = document.createElement('script');
    script.src = "https://consent.truste.com/notice?domain=hindugroup.com&c=teconsent&gtm=1&pcookie&js=nj&noticeType=bb&privacypolicylink=https%3A%2F%2Fwww.thehindugroup.com%2Fprivacy.html";
    script.async = true;
    script.onload = function(){
    	 resolve(script);
    }
    script.onerror =function(){
   		 resolve(script);
   	}
    document.head.append(script);
  });
</script><script type="text/javascript" data-cfasync="false">
function appURL(){	
	return "https://frontline.thehindu.com/";
}
function pageType(){	
	return "art";
}
var DevIdf = {
	isMobile: false,
	isTablet: false,
	isDesktop: false,
	isLargeDesktop: false
};
var ClientdeviceType = {
	"xlarge": "(min-width: 1600px)",
	"large": "(min-width: 1024px) and (max-width: 1599px)",
	"small": "(max-width: 767px)",
	"medium": "(min-width: 768px) and (max-width: 1023px)"
};

function isDeviceEnabled(DeviceValue) {if (DeviceValue == "large" && (DevIdf.isDesktop || DevIdf.isLargeDesktop)) {
		return true;
	}else if (DeviceValue == "medium" && DevIdf.isTablet) {
		return true;
	} else if (DeviceValue == "small" && DevIdf.isMobile) {
		return true;
	}
	return false;
}
for (var type in ClientdeviceType) {
	if (window.matchMedia(ClientdeviceType[type]).matches) {
		switch (type) {
			case "xlarge":
				DevIdf.isLargeDesktop = true;
				break;
			case "large":
				DevIdf.isDesktop = true;
				break;
			case "medium":
				DevIdf.isTablet = true;
				break;
			case "small":
				DevIdf.isMobile = true;
				break;
		}
		break;
	}
}
function loadScript(url) {
		var s = document.createElement('script');
		s.type = 'text/javascript';
		s.async = true;
		s.src = url;
		var x = document.getElementsByTagName('script')[0];
		x.appendChild(s);
}

function loadCSS(url) {
		var link = document.createElement('link');
		link.rel = 'stylesheet';
		link.href = url;
		link.type = 'text/css';
		var el = document.getElementsByTagName('link')[0];
		el.parentNode.insertBefore(link, el);
} 
function getUrlParameter( name, url ) {
if (!url) url = location.href;
name = name.replace(/[\[]/,"\\\[").replace(/[\]]/,"\\\]");
var regexS = "[\\?&]"+name+"=([^&#]*)";
var regex = new RegExp(regexS,"i");
var results = regex.exec( url );
return results == null ? null : results[1];
}
function createCookie(name,value,days) { if (days) {
var date = new Date();
date.setTime(date.getTime()+(days*24*60*60*1000));
var expires = "; expires="+date.toGMTString();
}
else var expires = "";
document.cookie = name+"="+value+expires+"; path=/";
}
function eraseCookie(name) {
createCookie(name,"",-1);
}
function readCookie(name) {
var nameEQ = name + "=";
var ca = document.cookie.split(';');
for(var i=0;i < ca.length;i++) {
var c = ca[i];
while (c.charAt(0)==' ') c = c.substring(1,c.length);
if (c.indexOf(nameEQ) == 0) return c.substring(nameEQ.length,c.length);
}
return null;
}
function deleteCookie(name) {
createCookiewithdomain(name,null,-1);
}
function createCookiewithdomain(name,value,days) {
if (days) {
var date = new Date();
date.setTime(date.getTime()+(days*24*60*60*1000));
var expires = "; expires="+date.toGMTString();
}
else var expires = "";
document.cookie = name+"="+value+expires+"; domain="+document.location.host.match(/\.[.\w]*/)+";path=/";
}
function getStorage(name){	if(typeof(Storage) !== "undefined" && 'localStorage' in window && window.localStorage !== null) {	if (localStorage.getItem(name)){	cookieObj = JSON.parse(localStorage.getItem(name));
if (cookieObj !== undefined && (cookieObj.e == null || cookieObj.e > new Date())){return cookieObj.v === undefined ? null : cookieObj.v ; }	else{localStorage.removeItem(name);}	}
return null;	} else {return readCookie(name);}	}
function setStorage(name,value,days){
if(typeof(Storage) !== "undefined" && 'localStorage' in window && window.localStorage !== null) {
var date = new Date();	localStorage.setItem(name,JSON.stringify({"v":value, "e":date.setTime(date.getTime()+(days*24*60*60*1000))}))
} else {createCookie(name,value,days);}	}
function eraseStorage(name){ if(typeof(Storage) !== "undefined" && 'localStorage' in window && window.localStorage !== null) {localStorage.removeItem(name);}
else{eraseCookie(name)}
}
var isNonSubcribed = true;function isNonSubcribedUser(){return isNonSubcribed;}
var myUserStatus = "anon";function UserCurrentStatus(){return myUserStatus;}var promiseResolve, promiseReject;userIdentify = new Promise(function(resolve, reject){promiseResolve = resolve;promiseReject = reject;});var thg={required:!0,functional:!1,advertising:!1,requiredCookie:function(){return thg.required},functionalCookie:function(){return thg.functional},advertisingCookie:function(){return thg.advertising}};thgCookieConsent.then(function(){var constentbehavior=readCookie("notice_behavior"),cookieconsent=readCookie("cmapi_cookie_privacy");null==cookieconsent&&null!=constentbehavior&&-1==constentbehavior.indexOf("eu")?(thg.functional=!0,thg.advertising=!0):null!==cookieconsent?(cookieconsent.indexOf("permit")>-1&&cookieconsent.indexOf("2")>-1&&(thg.functional=!0),cookieconsent.indexOf("permit")>-1&&cookieconsent.indexOf("3")>-1&&(thg.advertising=!0)):null==constentbehavior&&(thg.functional=!0,thg.advertising=!0);});
</script><script data-cfasync="false">
var _paq = window._paq || [];
</script><script data-cfasync="false">
    document.cookie = "__adblocker=; expires=Thu, 01 Jan 1970 00:00:00 GMT; path=/";
    var setNptTechAdblockerCookie = function(adblocker) {
        var d = new Date();
        d.setTime(d.getTime() + 60 * 5 * 1000);
        document.cookie = "__adblocker=" + (adblocker ? "true" : "false") + "; expires=" + d.toUTCString() + "; path=/";
    };
    var script = document.createElement("script");
    script.setAttribute("async", true);
    script.setAttribute("src", "//www.npttech.com/advertising.js");
    script.setAttribute("onerror", "setNptTechAdblockerCookie(true);");
    document.getElementsByTagName("head")[0].appendChild(script);
</script><script type="text/javascript" data-cfasync="false" src="https://cdn.cxense.com/cx.cce.js" async></script><script data-cfasync="false" type="text/javascript"> 
var cX = window.cX = window.cX || { callQueue: [], options: { dataLayer: { cookie: { domain: '.frontline.thehindu.com' } }}}; 
cX.CCE = cX.CCE || {}; cX.CCE.callQueue = cX.CCE.callQueue || []; 
cX.callQueue.push(["setSiteId","1128458718543440953"]); 
cX.CCE.callQueue.push(["sendPageViewEvent", "thg", "6ccaf530673bc21409a43a45300ef01e63095338"]); 
</script><script data-cfasync="false">(function(src) { var a = document.createElement("script"); a.type = "text/javascript"; a.async = true; a.src = src; var b = document.getElementsByTagName("script")[0]; b.parentNode.insertBefore(a, b) })("https://experience.tinypass.com/xbuilder/experience/load?aid=7JJs2o4rpu"); 
tp = window["tp"] || [];tp.push(["setContentCreated", "2022-10-25T12:17:49+0530"]); 
tp.push(["setContentAuthor", "Deutsche Welle"]);
tp.push(["setContentSection", "News"]);
tp.push(["setTags", []]); 
tp.push(["setContentIsNative", false]); 
tp.push(["setZone", (DevIdf.isMobile === true ? 'MobileWeb' : 'Web')]);</script><script>
window.adfiller = window.adfiller || [];
window.googletag = window.googletag || {cmd: []};
window.PWT = window.PWT || {};
</script><script>
function loadGptScript(){
	var gads = document.createElement('script');
	var useSSL = 'https:' == document.location.protocol;
	gads.src = (useSSL ? 'https:' : 'http:') + '//securepubads.g.doubleclick.net/tag/js/gpt.js';
	var node = document.getElementsByTagName('script')[0];
	node.parentNode.insertBefore(gads, node);
}Promise.all([userIdentify, thgCookieConsent]).then(function() {
if(isNonSubcribedUser() && thg.advertisingCookie()){}
});  
</script><script>
googletag.cmd.push(function () {googletag.pubads().enableSingleRequest();
googletag.pubads().setTargeting('Section', ['news']);googletag.pubads().setTargeting('articleid', ['66053268']);googletag.pubads().enableLazyLoad();googletag.enableServices();
});</script><script>
var dataLayer = window.dataLayer || [];
</script><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-N24644H');
</script><script type="text/javascript">thgCookieConsent.then(function() {if(thg.functionalCookie()){var userconsent = 1 ;var _comscore = _comscore || [];  _comscore.push({ c1: "2", c2: "11398210",cs_ucfr: userconsent});  (function() {    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;s.src=(document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";    el.parentNode.insertBefore(s, el);  })();}});</script><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=123456&cs_ucfr=1&cv=2.0&cj=1" /></noscript><style>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</style></head><body class="base-font bg-white news"><meta itemprop="headline" content="Inside Myanmar’s anti-junta rebel forces" /><meta itemprop="description" content="Ethnic rebels wage jungle warfare against the military dictatorship in hopes of restoring democracy." /><meta itemprop="datePublished" content="2022-10-25T17:47:49+05:30" /><meta itemprop="dateModified" content="2022-10-25T17:47:51+05:30" /><meta itemprop="url" content="https://frontline.thehindu.com/news/inside-myanmar-anti-junta-rebel-forces/article66053268.ece" /><meta itemprop="keywords" content="Inside Myanmar’s anti-junta rebel forces,myanmar,myanmar junta,aung san suu kyi,national unity government,democracy,military dictatorship,karen state" /><meta itemprop="articleSection" content="News" /><span itemscope="itemscope" itemprop="author" itemtype="https://schema.org/Person" /><meta content="Deutsche Welle" itemprop="name" /><meta itemprop="url" content="https://frontline.thehindu.com/profile/author/Deutsche-Welle-16448/" /></span><span itemtype="https://schema.org/ImageObject" itemscope="itemscope" itemprop="image" /><meta itemprop="url" content="https://fl-i.thgim.com/public/incoming/o7ti32/article66053254.ece/alternates/FREE_1200/myanmar%20anti%20junta.jpg" /><meta content="1200" itemprop="width" /><meta content="749" itemprop="height" /></span><span itemtype="https://schema.org/Organization" itemscope="itemscope" itemprop="publisher" /><span itemtype="https://schema.org/ImageObject" itemscope="itemscope" itemprop="logo" /><meta content="https://frontline.thehindu.com/theme/images/fl-online/fl-logo-amp.png" itemprop="url" /><meta content="600" itemprop="width" /><meta content="60" itemprop="height" /></span><meta content="Frontline" itemprop="name" /><meta content="https://frontline.thehindu.com/" itemprop="url" /></span><span itemprop="mainEntityOfPage" itemscope="itemscope" itemtype="https://schema.org/WebPage" /><meta content="https://frontline.thehindu.com/news/inside-myanmar-anti-junta-rebel-forces/article66053268.ece" itemprop="url" /></span><meta itemprop="isAccessibleForFree" content="false" /><div itemprop="isPartOf" itemscope itemtype="http://schema.org/CreativeWork http://schema.org/Product"><meta itemprop="name" content="Frontline" /><meta itemprop="productID" content="frontline.thehindu.com:showcase" /></div><span itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="Frontline" /><meta itemprop="url" content="https://frontline.thehindu.com/" /><meta itemprop="logo" content="https://frontline.thehindu.com/theme/images/fl-online/fl-logo-amp.png" /><span itemprop="address" itemscope itemtype="https://schema.org/PostalAddress"><meta itemprop="streetAddress" content="Kasturi Building, Anna Salai, 859-860, Mount Road" /><meta itemprop="addressLocality" content="Chennai" /><meta itemprop="addressRegion" content="Tamil Nadu" /><meta itemprop="postalCode" content="600002" /><meta itemprop="Telephone" content="+91-44-2857 6300" /></span><meta itemprop="sameAs" content="https://www.facebook.com/frontline" /><meta itemprop="sameAs" content="https://twitter.com/frontline_india" /><meta itemprop="sameAs" content="" /><meta itemprop="sameAs" content="" /></span><noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-N24644H"
      height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><section class="fullWidthCss"><div class="container-fluid top-add"></div></section><header class="blog-header flhome flredbackcolor"><div class="container"><div class="row justify-content-between align-items-center"><div class="col-12 col-md-6  pt-1 navbar-light"><button class="navbar-toggler d-block d-sm- block d-md-block d-lg-none" type="button" data-bs-toggle="collapse" data-bs-target="#navbarNav" aria-controls="navbarNav" aria-expanded="false" aria-label="Toggle navigation"><span class="icon-bar"></span><span class="icon-bar"></span><span class="icon-bar"></span></button><div id="logo-print" class="fllogo"><div class="logo-block"><a href="https://frontline.thehindu.com/"><img src="https://frontline.thehindu.com/theme/images/fl-online/fllogo.png" alt="Return to frontpage" width="100%" height="100%"></a></div><div class="flcolorwhite pull-right issueHeader d-none d-sm-none d-md-none d-lg-block">
INDIA's NATIONAL MAGAZINE
</div></div></div><div class="col-12 col-md-3 text-center submobsticky"><div class="subsEntrymenu d-none d-lg-block"><ul><li class="Subscribebtn Subscribebtnremove subscribeBtnCss" data-category="SUBSCRIBE NOW icon" data-label="home-page"><a href="https://frontline.thehindu.com/online-subscription?utm_source=Website&utm_medium=Header&utm_campaign=Subsbutton">Subscribe Now</a></li><li class="dropdown signinbtn signedInUserBtn" data-category="Sign in/up icon" data-label="home-page"><a class="sso-signin thgsignin" id="sso-signin">Sign In</a></li></ul></div><div class="mobileadsubentry d-block d-sm-none readPremiumDiv"><a href="/online-subscription/?utm_source=MWeb&amp;utm_medium=HomepageHeader&amp;utm_campaign=SubscribeNowlink" class="mobileadsubentryremoveads">
Read Premium Articles - </a><a href="/online-subscription/?utm_source=MWeb&amp;utm_medium=HomepageHeader&amp;utm_campaign=SubscribeNowlink" class="mobileadsubentryfreetrail Subscribebtn">
Subscribe Now
</a></div><div class="d-block d-lg-none submobileentry"><div class="sigininmobile sso-signin" id="mobilesignin" data-category="Sign in/up icon" data-label="home-page"><a class="sso-signin thgsignin" id="mobilesigninlink"><i class="fa fa-user"></i></a></div></div></div><script type="text/javascript">
var els = document.querySelectorAll("#main-menu>ul>li:nth-last-child(-n+2)");
[].forEach.call(els, function(els) {
els.style.display = "none";
});
  	tp = window["tp"] || [];
	tp.push(['init',function() {
        if (!tp.user.isUserValid()) {
        document.getElementsByClassName("subsEntrymenu").length > 0 ? document.getElementsByClassName("subsEntrymenu")[0].style.display = "block" : '';
        document.getElementsByClassName("submobileentry").length > 0 ? document.getElementsByClassName("submobileentry")[0].style.display = "block" : '';
        }
        tp.pianoId.init({            
            loggedIn : function(data) {
                thgloggedIn(data)
            },
            loggedOut : function() {
                location.reload();
            }
        });
	}]);
    
function thgloggedIn(data) {
isUserDetails = data;
var userName = typeof tp.pianoId.getUser().firstName != "undefined" ? "Hi " + tp.pianoId.getUser().firstName : 'Hi User';
var mobuserName = typeof tp.pianoId.getUser().firstName != "undefined" ? " " + tp.pianoId.getUser().firstName : 'User';
document.getElementById("sso-signin") != null ? document.getElementById("sso-signin").innerHTML = "<i class='fa fa-user'></i>"+userName :'';
document.getElementById("sso-signin") != null ? document.getElementById("sso-signin").classList.remove("thgsignin"):'';
document.getElementById("mobilesignin") != null ? document.getElementById("mobilesignin").classList.remove("sso-signin"):'';
document.getElementById("mobilesignin") != null ? document.getElementById("mobilesignin").classList.add("sso-signinmobile"):'';
document.getElementById("mobilesigninlink") != null ? document.getElementById("mobilesigninlink").classList.remove("thgsignin"):'';
if(DevIdf.isMobile == true){
var dropdown = '<ul class="dropdown-menu sso-signinuser mobileThsubscrip1">'
+ '<li class="mobileusername" ><a class="" ><img src="../../../../theme/images/fl-online/user_navigation.png" class="mobusericon"><span class="mobileusernamespan"> Hello <br><b>'
+ mobuserName
+ '</b></span><span class="closeicon"> &#10005;</span></a><hr>'
/* + tp.pianoId.getUser().email */
+ '<li data-category="Hi user" data-label="My Account"><a href="/myaccount/" class="sso-profile">My Account</a>'
+ '<li data-category="Hi user" data-label="FAQ"><a href="/faq/" target="_blank" class="sso-profile">FAQS</a>'
+ '<li data-category="Hi user" data-label="Contact us"><a href="/contacts/" target="_blank" class="sso-profile">Contact Us</a>'
+ '<li data-category="Hi user" data-label="Sign Out"><a class="sso-logout" onclick="tp.user.logout()" >Sign Out</a>'
+ '</ul>';
}else {
var dropdown = '<ul class="dropdown-menu sso-signinuser">'
+ '<li class="mobileusername" ><a class="" >'
+ userName
+ '</a>'
+ '<li data-category="Hi user" data-label="My Account"><a href="/myaccount/" class="sso-profile">My Account</a>'
+ '<li data-category="Hi user" data-label="FAQ"><a href="/faq/" target="_blank" class="sso-profile">FAQS</a>'
+ '<li data-category="Hi user" data-label="Contact us"><a href="/contacts/" target="_blank" class="sso-profile">Contact Us</a>'
+ '<li data-category="Hi user" data-label="Sign Out"><a class="sso-logout" onclick="tp.user.logout()" >Sign Out</a>'
+ '</ul>';
}
var list = document.querySelectorAll(".signinbtn");
for (var i = 0; i < list.length; ++i) {
list[i].classList.remove('subscribeBtnCss');
list[i].classList.add('ssologin');
list[i].insertAdjacentHTML('beforeend', dropdown);
}
var listmobile = document.querySelectorAll(".sigininmobile");
for (var i = 0; i < listmobile.length; ++i) {
listmobile[i].insertAdjacentHTML('beforeend', dropdown);
}
document.getElementsByClassName("subsEntrymenu").length > 0 ? document.getElementsByClassName("subsEntrymenu")[0].style.display = "block" : '';
document.getElementsByClassName("submobileentry").length > 0 ? document.getElementsByClassName("submobileentry")[0].style.display = "block" : '';
}
	function thgLogout() {
	typeof __thg_event != "undefined" ?  __thg_event.triggerLogOut(tp.pianoId.getUser()): null;
	   tp.push(["init", function () {
	        tp = window.tp || [];
	        tp.pianoId.logout()
	        location.reload();
	   }]);
    }
</script><div class="col-12 col-md-3 d-flex justify-content-end align-items-center d-none d-lg-block socialHeadDiv"><div class="socialHeader flcolorwhite"><div class="pull-left followDiv"><p>Follow us on</p></div><div class="socialize pull-right"><ul><li><a href="https://www.facebook.com/frontlineindia/" class="fb back83050b" target="_blank"><i class="fa fa-facebook"></i></a></li><li><a href="https://twitter.com/frontline_india" class="tw back83050b" target="_blank"><i class="fa fa-twitter"></i></a></li><li><a href="https://www.instagram.com/frontline.magazine/" class="tw back83050b" target="_blank"><i class="fa fa-instagram"></i></a></li></ul></div></div><div class="flcolorwhite searchWrap"><p>| <i class="fa fa-search" onclick="searchClickfn()"></i><div id="hidden-form" style="display: none;"><form action="https://frontline.thehindu.com/search/" id="fl-search"><input id="search-txt-bloc" name="q" type="text" placeholder="Search here" data-type="search" /></form></div></p></div></div></div></div><div class="menubg"><nav id="navbar_top" class="navbar navbar-expand-lg navbar-light"><div class="container bxs"><button class="navbar-toggler d-none" type="button" data-bs-toggle="collapse" data-bs-target="#navbarNav" aria-controls="navbarNav" aria-expanded="false" aria-label="Toggle navigation"><span class="navbar-toggler-icon"></span></button><div class="collapse navbar-collapse" id="navbarNav"><div class="d-block d-lg-none"><div class="flcolorwhite searchWrap"><form action="https://frontline.thehindu.com/search/" id="search"><div class="input-group"><input id="simplesearch" name="q" type="text" placeholder="Search here" data-type="search" /><div class="input-group-btn"><button class="btn btn-default" type="submit"><i class="fa fa-search"></i></button></div></div></form></div></div>
<ul class="navbar-nav me-auto mb-2 mb-md-0">
<li class="nav-item">
<a class="nav-link" href="https://frontline.thehindu.com/">
<i class="fa fa-home"></i>
</a>
</li>
<li class=" nav-item dropdown active">
<a class="nav-link" target="_self" href="https://frontline.thehindu.com/news/" id="dropdown04" aria-expanded="false">
News<span class="fa fa-angle-down hplinkdown"></span></a> <div class="subtwoMenu News">
<a class="nav-link dropdown-toggle d-block d-lg-none" href="#" id="dropdown-sub" data-bs-toggle="dropdown" aria-expanded="false"></a>
<ul class="dropdown-menu" aria-labelledby="dropdown04">
<li><a class="nav-item dropdown" href="https://frontline.thehindu.com/the-nation/">India</a></li>
<li><a class="nav-item dropdown" href="https://frontline.thehindu.com/world-affairs/">World Affairs</a></li>
<li><a class="nav-item dropdown" href="https://frontline.thehindu.com/other/sport/">Sports</a></li>
<li><a class="nav-item dropdown" href="https://frontline.thehindu.com/environment/">Environment</a></li>
</ul>
</div>
</li>
<li class=" nav-item dropdown ">
<a class="nav-link" target="_self" href="https://frontline.thehindu.com/columns/" id="dropdown04" aria-expanded="false">
Columns<span class="fa fa-angle-down hplinkdown"></span></a> <div class="subtwoMenu Columns">
<a class="nav-link dropdown-toggle d-block d-lg-none" href="#" id="dropdown-sub" data-bs-toggle="dropdown" aria-expanded="false"></a>
<ul class="dropdown-menu" aria-labelledby="dropdown04">
<li><a class="nav-item dropdown" href="https://frontline.thehindu.com/columns/sabyasachi-bhattacharya/">Sabyasachi Bhattacharya</a></li>
<li><a class="nav-item dropdown" href="https://frontline.thehindu.com/columns/C_P_Chandrasekhar/">C.P. Chandrasekhar</a></li>
</ul>
</div>
</li>
<li class=" nav-item dropdown ">
<a class="nav-link" target="_self" href="https://frontline.thehindu.com/arts-and-culture/" id="dropdown04" aria-expanded="false">
Arts &amp; Culture<span class="fa fa-angle-down hplinkdown"></span></a> <div class="subtwoMenu Arts &amp; Culture">
<a class="nav-link dropdown-toggle d-block d-lg-none" href="#" id="dropdown-sub" data-bs-toggle="dropdown" aria-expanded="false"></a>
<ul class="dropdown-menu" aria-labelledby="dropdown04">
<li><a class="nav-item dropdown" href="https://frontline.thehindu.com/arts-and-culture/art/">Art</a></li>
<li><a class="nav-item dropdown" href="https://frontline.thehindu.com/arts-and-culture/cinema/">Cinema</a></li>
<li><a class="nav-item dropdown" href="https://frontline.thehindu.com/arts-and-culture/heritage/">Heritage</a></li>
<li><a class="nav-item dropdown" href="https://frontline.thehindu.com/arts-and-culture/literature/">Literature</a></li>
<li><a class="nav-item dropdown" href="https://frontline.thehindu.com/arts-and-culture/music/">Music</a></li>
</ul>
</div>
</li>
<li class=" nav-item dropdown ">
<a href="https://frontline.thehindu.com/social-issues/" class="nav-link" title="Social Issues" target="_self">Social Issues</a>
</li>
<li class=" nav-item dropdown ">
<a href="https://frontline.thehindu.com/economy/" class="nav-link" title="Economy" target="_self">Economy</a>
</li>
<li class=" nav-item dropdown ">
<a href="https://frontline.thehindu.com/the-nation/public-health/" class="nav-link" title="Health" target="_self">Health</a>
</li>
<li class=" nav-item dropdown ">
<a href="https://frontline.thehindu.com/science-and-technology/" class="nav-link" title="Science &amp; Technology" target="_self">Science &amp; Technology</a>
</li>
<li class=" nav-item dropdown ">
<a href="https://frontline.thehindu.com/books/" class="nav-link" title="Books" target="_self">Books</a>
</li>
<li class=" nav-item dropdown ">
<a href="https://frontline.thehindu.com/other/data-card/" class="nav-link" title="Data Stories" target="_self">Data Stories</a>
</li>
<li class=" flmenus d-block d-lg-none d-xl-block  nav-item dropdown ">
<a class="nav-link" target="_self" href="https://frontline.thehindu.com/other/" id="dropdown04" aria-expanded="false">
Other<span class="fa fa-angle-down hplinkdown"></span></a> <div class="subtwoMenu Other">
<a class="nav-link dropdown-toggle d-block d-lg-none" href="#" id="dropdown-sub" data-bs-toggle="dropdown" aria-expanded="false"></a>
<ul class="dropdown-menu" aria-labelledby="dropdown04">
<li><a class="nav-item dropdown" href="https://frontline.thehindu.com/editors-pick/">Editor&#039;s Pick</a></li>
<li><a class="nav-item dropdown" href="https://frontline.thehindu.com/afghan-file/">Afghan File</a></li>
<li><a class="nav-item dropdown" href="https://frontline.thehindu.com/covid-19/">Covid-19</a></li>
<li><a class="nav-item dropdown" href="https://frontline.thehindu.com/politics/">Politics</a></li>
<li><a class="nav-item dropdown" href="https://frontline.thehindu.com/economy/">Economy</a></li>
<li><a class="nav-item dropdown" href="https://frontline.thehindu.com/social-issues/">Social Issues</a></li>
<li><a class="nav-item dropdown" href="https://frontline.thehindu.com/books/">Books</a></li>
<li><a class="nav-item dropdown" href="https://frontline.thehindu.com/social-issues/gender/">Gender</a></li>
<li><a class="nav-item dropdown" href="https://frontline.thehindu.com/social-issues/general-issues/">General Issues</a></li>
<li><a class="nav-item dropdown" href="https://frontline.thehindu.com/social-issues/social-justice/">Social Justice</a></li>
<li><a class="nav-item dropdown" href="https://frontline.thehindu.com/environment/">Environment</a></li>
<li><a class="nav-item dropdown" href="https://frontline.thehindu.com/environment/conservation/">Conservation</a></li>
<li><a class="nav-item dropdown" href="https://frontline.thehindu.com/environment/wild-life/">Wildlife</a></li>
<li><a class="nav-item dropdown" href="https://frontline.thehindu.com/other/letters/">Letters</a></li>
<li><a class="nav-item dropdown" href="https://frontline.thehindu.com/other/obituary/">Obituary</a></li>
<li><a class="nav-item dropdown" href="https://frontline.thehindu.com/other/travel/">Travel</a></li>
<li><a class="nav-item dropdown" href="https://frontline.thehindu.com/other/advertorial/">Advertorial</a></li>
</ul>
</div>
</li>
<li class=" flmenus d-block d-lg-none d-xl-block  nav-item dropdown ">
<a href="https://frontline.thehindu.com/current-issue/" class="nav-link" title="Current Issue" target="_self">Current Issue</a>
</li>
<li class=" flmenus d-block d-lg-none d-xl-block  nav-item dropdown ">
<a href="https://frontline.thehindu.com/magazine/" class="nav-link" title="Archives" target="_self">Archives</a>
</li>
</ul>
</div></div></nav></div></header><article class="articlepage storyline" data-id="66053268" data-url="https://frontline.thehindu.com/news/inside-myanmar-anti-junta-rebel-forces/article66053268.ece" data-title="Inside Myanmar’s anti-junta rebel forces"><div class="container"><div class="artConPage m-0 p-0 floatShr"><div class="row"><div class="main col-12 col-md-12 col-lg-9  maincont"><div class="article"><div class="secheader ece_frontpage news" id="news"><ul class="breadcrumb my-2" itemscope="" itemtype="https://schema.org/BreadcrumbList"><li itemprop="itemListElement" itemscope="" itemtype="https://schema.org/ListItem"><a href="https://frontline.thehindu.com/news/" itemtype="https://schema.org/Thing" itemprop="item"><span itemprop="name">News</span></a><meta itemprop="position" content="1"></li></ul></div><div class="news mb-3"><div class="overline  py-1 ece_frontpage news">Southeast Asia</div><h1 itemprop="name" class="title  py-1">
Inside Myanmar’s anti-junta rebel forces
</h1></div><div class="mb-3"><a href="https://frontline.thehindu.com/profile/author/Deutsche-Welle-16448/" class="mobile-auth-nm lnk">Deutsche Welle</a></div><div class="article-container"><div class="row"><div class=" col-12  col-xl-11"><div class="imgPart col-lg-12 articleCarousel"><div class="articleBottomLine mb-2"><span class="ksl-time-stamp">
Print edition : Oct 25, 2022
</span><span class="fontincrease pull-right d-none d-md-block"><span class="increase1">T+</span><span class="decrease1">T-</span></span></div><div class="clearfix"></div></div><div class="mobilesocialicons d-block d-xl-none"><ul class="aricle-share"><li data-label="Facebook" data-category="social-shares"><a href="javascript:void(0);" onclick="openShareLink('https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Ffrontline.thehindu.com%2Fnews%2Finside-myanmar-anti-junta-rebel-forces%2Farticle66053268.ece&amp;t=Inside%20Myanmar%E2%80%99s%20anti-junta%20rebel%20forces')"><i class="fa fa-facebook fb"></i><span class="cnt"></span></a></li><li data-label="Twitter" data-category="social-shares"><a href="javascript:void(0);" onclick="openShareLink('https://twitter.com/intent/tweet?url=https%3A%2F%2Ffrontline.thehindu.com%2Fnews%2Finside-myanmar-anti-junta-rebel-forces%2Farticle66053268.ece&amp;text=Inside%20Myanmar%E2%80%99s%20anti-junta%20rebel%20forces')"><i class="fa fa-twitter tw"></i></a></li><li data-label="WhatsApp" data-category="social-shares"><a href="javascript:void(0);" onclick="openShareLink('https://api.whatsapp.com//send?text=Inside%20Myanmar%E2%80%99s%20anti-junta%20rebel%20forces%20-%20https%3A%2F%2Ffrontline.thehindu.com%2Fnews%2Finside-myanmar-anti-junta-rebel-forces%2Farticle66053268.ece')"><i class="fa fa-whatsapp wa"></i></a></li><li><a href="mailto:?subject=Inside%20Myanmar%E2%80%99s%20anti-junta%20rebel%20forces&amp;amp;body=Check%20out%20this%20link%20https%3A%2F%2Ffrontline.thehindu.com%2Fnews%2Finside-myanmar-anti-junta-rebel-forces%2Farticle66053268.ece" target="_self"><i class="fa fa-envelope en"></i></a></li></ul></div><div class="bodyMargin"><div class="topstoryparent fltopstoryparent"><h2 itemprop="name" class="title">
Inside Myanmar’s anti-junta rebel forces
</h2><div class="lead-img-cont "><div class="img-container picture artImgFree" style="width:100%"><picture><!--[if IE 9]><video style="display: none;"><![endif]--><source media="(min-width: 1600px)" sizes="960px" srcset="https://fl-i.thgim.com/public/incoming/o7ti32/article66053254.ece/alternates/FREE_1200/myanmar%20anti%20junta.jpg"><source media="(min-width: 768px) and (max-width: 1599px)" sizes="640px" srcset="https://fl-i.thgim.com/public/incoming/o7ti32/article66053254.ece/alternates/FREE_1200/myanmar%20anti%20junta.jpg"><source media="(min-width: 321px) and (max-width: 767px)" sizes="400px" srcset="https://fl-i.thgim.com/public/incoming/o7ti32/article66053254.ece/alternates/FREE_1200/myanmar%20anti%20junta.jpg"><source media="(max-width: 320px)" sizes="320px" srcset="https://fl-i.thgim.com/public/incoming/o7ti32/article66053254.ece/alternates/FREE_1200/myanmar%20anti%20junta.jpg"><!--[if IE 9]></video><![endif]--><img alt="Rebel fighters hope to bring down the Myanmar junta." src="https://frontline.thehindu.com/https://frontline.thehindu.com/theme/images/fl-online/1x1_spacer.png" data-original="https://frontline.thehindu.com/https://frontline.thehindu.com/theme/images/fl-online/1x1_spacer.png" class="lead-img media-object article-pictue"></picture><span class="lead-img-caption "><p>
Rebel fighters hope to bring down the Myanmar junta.
| Photo Credit: <a> Víctor Fernández Molina</a></p></span></div></div><div class="leadtext"><h4 class="intro">
Ethnic rebels wage jungle warfare against the military dictatorship in hopes of restoring democracy.
</h4></div><div id="content-body-66053268" itemprop="articleBody"><p>A dozen young soldiers in flip-flops prepare a mortar shot next to an abandoned shed nearly engulfed by the dense Burmese jungle. They are located near a road, which connects the towns of Myawaddy and Lay Lay Kay in Myanmar’s Karen State, close to the border with Thailand.</p><p>A year ago, these soldiers were engineering and law students, but following the military coup in February 2021 they decided to leave school and join the guerrillas. Now, they are an artillery squad from the Karen National Liberation Army (KNLA), an ethnic armed group which is a member of the pro-democracy alliance fighting the military government. The KNLA has spent months training new recruits. They are beginning to gain ground against Myanmar’s army, the Tatmadaw.</p><h2 class="sub_head">
Fighting an army with homemade weapons
</h2><p>Taking advantage of the clear morning sky, unit commander Saw Da Baw checks the coordinates on his cell phone while one of his men adjusts the crank. Saw Da Baw is a veteran soldier, already in his forties. He loads up a self-made 60 millimeter grenade and the projectile is fired towards a Tatmadaw base, located some 300 meters (around 330 yards) away.</p><p>The squadron’s cheer rings out above the explosion in the distance: It was a direct hit.</p><div id="piano-artmiddle" class="my-3"></div><p><b>ALSO READ: </b><a href="https://frontline.thehindu.com/dispatches/myanmar-faces-economic-collapse-one-year-after-military-coup/article65220400.ece" target="_blank">Myanmar faces economic collapse</a></p><p>Da Baw points up at the homemade drone that guided the shot: “Long live the Karen Air Force!” he quips. His troops do not have airplanes or helicopters like the Tatmadaw, but the new generation of recruits has proven to be versatile in improvising all kinds of weapons, including drones.</p><p>The Cobra Column, the name of this rebel regiment, is a multi-ethnic force, with Karen, Rohingya, and even Burmese — the majority ethnic group in Myanmar — among its ranks. Some are members of the KNLA, a group with more than 70 years of experience fighting the Tatmadaw. Others belong to the People’s Defense Forces (PDF), which formed after the coup and are more or less under the command of the National Unity Government (NUG), which is fighting for its legitimacy against the military.</p><h2 class="sub_head">
Why they fight
</h2><p>The violent repression of the army has united the group under the common goal of returning democracy to Myanmar. But each of them has a different story to tell about becoming a guerrilla fighter.</p><p>Nou Aprilsay, a 19-year-old Karen soldier from the Irrawaddy river delta, announced to her parents a year ago that she was leaving home to join the rebels. “I am not afraid of dying,” she told <i>DW</i>. “If I stayed in the city, the army would have raped and killed me like they did my friends. If I go down fighting, my death will at least serve the revolution.”</p><p>Thu Rain, a 26-year-old Burmese, says he had no choice but to fight after seeing his best friend die during a peaceful demonstration against the dictatorship. The date when his friend was killed by the military is now inscribed as a tattoo on Thu Rain’s hand. Thu Rain used to be an electrician. He is now a sniper. Another tattoo on his hand, this one listing possible settings for his scope, serves as a symbol of his new life.</p><p>When he killed a soldier for the first time, Thu Rain felt “that he was settling a debt, nothing more, nothing less,” he says while holding his Ruger sniper rifle, a modern American weapon that stands out from the guns wielded by his comrades.</p><p>Most of them carry M16s, Kalashnikovs, or MA rifles stolen from the Tatmadaw. “Despite everything, I’m not here for revenge. I fight to give people back the rights that were stolen from us,” he says.</p><h2 class="sub_head">
Rebels struggle with lack of supplies
</h2><p>In moments of calm, the soldiers take the opportunity to cook rice, play cards, sing and play a guitar that is missing a string. “We barely get medicines or the weapons we need,” says the guitar player as he chews on areca palm nut. “A string replacement is the least of our priorities.”</p><p>The harsh conditions in which the fighters live mean they can’t even provide proper treatment to soldiers suffering from malaria or dengue fever.</p><p><b>ALSO READ: </b><a href="https://frontline.thehindu.com/dispatches/myanmar-families-divided-over-education-amid-turmoil/article65220164.ece" target="_blank">Myanmar families divided over education amid turmoil</a></p><p>Fighter Khu Ree Du notes that other pro-democracy forces also struggle with the shortage of weapons and basic resources. The 26-year-old had run a farmers’ association until the military junta returned to power in February 2021. He is now a commander of the Karenni Nationalities Defence Force, another armed formation fighting against the coup masterminds.</p><p>“I would like to be Ukrainian,” Khu Ree Du says, noting with frustration the massive aid shipments send to Ukraine by Western governments. “Europe has a lot at stake in Ukraine, but here we’ve been fighting for more than a year against the dictatorship and the genocide and it is as if we do not exist,” he adds. “Luckily, where we lack guns, we find will.”</p><h2 class="sub_head">
“No one will rescue us but ourselves”
</h2><p>As the oppression of the junta grows stronger, more young people join what they call a democratic revolution.</p><p>At 17, Ma Ye Ynint M’ay is too young to be a soldier, according to the alliance’s rules. But this girl, a member of the Bamar ethnic group, says she can’t go back to her hometown after she was involved in a bombing attack on a building housing security forces.</p><p>“No one forced me to join the revolution,” she says with conviction. “In Thailand, a group of kids got stuck in a cave and all the international community went there to help them,” says the 17-year-old, referring to the tense Tham Luang cave rescue in 2018.</p><p>“Here teenagers like me die by the hundreds every week killed by hunger, airstrikes and even executions, but no one cares. That’s why the youth need to fight,” she says. “Because no one will come here to rescue us but ourselves.”</p><p>After two months attacking military bases and planting landmines targeting the Tatmadaw patrols, Ye Ynint M’ay and her family fled to an area controlled by the Karen National Defence Organisation. There, rebel officials granted her an exemption that allowed her to join the ranks of the People’s Defense Forces. She has now finished her training as a PDF commando and even found love with another guerrilla fighter while awaiting the next call to front line.</p><p><b>ALSO READ: </b><a href="https://frontline.thehindu.com/dispatches/explained-southeast-asia-muted-response-to-the-ukraine-conflict/article65220142.ece" target="_blank">Southeast Asia’s muted response to Ukraine conflict</a></p><p>Veteran leader Khu Hte Bu is 62 years old and has been challenging several Myanmar dictatorships from the jungle for more than 40 years. “I am now a deputy minister of the unity government,” he says. “The Burmese people have enjoyed some years of democracy and that has changed the minds of many, allowing us to unite against the military.”</p><p>Speaking from decades-long experience, Khu Hte Bu predicts a future full of challenges and sacrifices. “We have the support of the people, the right and the will to win this fight,” he says. “There is a chance to create a nation for everyone for the first time in our history. But the Burmese military has China and Russia behind it. Who do we have?”</p></div></div></div><div id="articleblockcontainer"></div><div class="vukkleDiv mb-3"></div></div><div class=" col-12  col-xl-1 p-0"><div class="shareicon-article d-none d-xl-block"><ul class="aricle-share"><li data-label="Facebook" data-category="social-shares"><a href="javascript:void(0);" onclick="openShareLink('https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Ffrontline.thehindu.com%2Fnews%2Finside-myanmar-anti-junta-rebel-forces%2Farticle66053268.ece&amp;t=Inside%20Myanmar%E2%80%99s%20anti-junta%20rebel%20forces')"><i class="fa fa-facebook fb"></i><span class="cnt"></span></a></li><li data-label="Twitter" data-category="social-shares"><a href="javascript:void(0);" onclick="openShareLink('https://twitter.com/intent/tweet?url=https%3A%2F%2Ffrontline.thehindu.com%2Fnews%2Finside-myanmar-anti-junta-rebel-forces%2Farticle66053268.ece&amp;text=Inside%20Myanmar%E2%80%99s%20anti-junta%20rebel%20forces')"><i class="fa fa-twitter tw"></i></a></li><li data-label="WhatsApp" data-category="social-shares"><a class="d-block d-lg-none" href="javascript:void(0);" onclick="openShareLink('https://api.whatsapp.com//send?text=Inside%20Myanmar%E2%80%99s%20anti-junta%20rebel%20forces%20-%20https%3A%2F%2Ffrontline.thehindu.com%2Fnews%2Finside-myanmar-anti-junta-rebel-forces%2Farticle66053268.ece')"><i class="fa fa-whatsapp wa"></i></a></li><li><a href="mailto:?subject=Inside%20Myanmar%E2%80%99s%20anti-junta%20rebel%20forces&amp;amp;body=Check%20out%20this%20link%20https%3A%2F%2Ffrontline.thehindu.com%2Fnews%2Finside-myanmar-anti-junta-rebel-forces%2Farticle66053268.ece" target="_self"><i class="fa fa-envelope en"></i></a></li><li><a class="d-none d-md-block" onClick="window.print(); return false"><i class="fa fa-print print"></i></a></li></ul></div></div></div></div></div><div class="scrollend"></div></div><div class="aside col-12 col-md-12 col-lg-3 mt-5"><div class="artAsidePiano1"></div><div class="artAsidePiano2"></div><div class="painoStickyaside"></div></div><div class="artShrEnd"></div><div id="people-you-like"></div></div></div></div></article><div data-include="article-footer-frontline"><footer class="footWrap footborder "><div id="artmeterwrap"></div><div class="container"><div class="footer-logo"><a href="https://frontline.thehindu.com/"><img src="https://frontline.thehindu.com/theme/images/fl-online/frontline-logo.png" class="img-fluid mobile-logo" alt="The Hindu frontline Logo" width="100%" height="100%"></a></div><div class="row footer-menu deskMenuFooter">
<div class="col-md-2 col-sm-2 col-12">
<ul class="footer-list">
<li class="title">
<h5 class="footer-top-border top-border-hide-mobile"><span class="footer-arrow">Frontline</span></h5>
<ul class="footer-sub-list">
<li class="">
<a class="" href=https://frontline.thehindu.com/aboutus/>About Us</a>
</li>
<li class="">
<a class="" href=https://frontline.thehindu.com/magazine/>News Archive</a>
</li>
<li class="">
<a class="" href=https://frontline.thehindu.com/current-issue/>Current Issue</a>
</li>
<li class="">
<a class="" href=https://frontline.thehindu.com/sitemap/>Site map</a>
</li>
<li class="">
<a class="" href=https://frontline.thehindu.com/subscription/>Print Subscription</a>
</li>
<li class="">
<a class="" href=https://frontline.thehindu.com/online-subscription/>Digital Subscription</a>
</li>
<li class="">
<a class="" href=https://frontline.thehindu.com/rssfeeds/>RSS feeds</a>
</li>
</ul>
</li>
<li class="title mt-4">
<h5 class="no-border"><span class="footer-arrow">Contact us</span></h5>
<ul class="footer-sub-list">
<li class="">
<a class="" href=https://frontline.thehindu.com/contacts/>Newsroom</a>
</li>
<li class="">
<a class="" href=https://frontline.thehindu.com/contacts/>Customer care</a>
</li>
<li class="">
<a class="" href=https://in.linkedin.com/school/the-hindu/jobs?trk=nav_type_jobs>Careers</a>
</li>
</ul>
</li>
</ul>
</div>
<div class="col-md-2 col-sm-2 col-12">
<ul class="footer-list">
<li class="title">
<h5 class="footer-top-border top-border-hide-mobile"><span class="footer-arrow">Group News Sites</span></h5>
<ul class="footer-sub-list">
<li class="">
<a class="" href=https://www.thehindu.com/>The Hindu</a>
</li>
<li class="">
<a class="" href=https://bloncampus.thehindubusinessline.com/>BL on Campus</a>
</li>
<li class="">
<a class="" href=https://sportstar.thehindu.com/>Sportstar</a>
</li>
<li class="">
<a class="" href=https://www.thehindubusinessline.com/>Businessline</a>
</li>
<li class="">
<a class="" href=https://www.hindutamil.in/>இந்து தமிழ் திசை</a>
</li>
<li class="">
<a class="" href=https://www.thehinducentre.com/>The Hindu Centre</a>
</li>
<li class="">
<a class="" href=https://ywc.thehindu.com/>Young World Club</a>
</li>
<li class="">
<a class="" href=https://epaper.thehindu.com/>The Hindu ePaper</a>
</li>
<li class="">
<a class="" href=https://epaper.thehindubusinessline.com/>Business Line ePaper</a>
</li>
<li class="">
<a class="" href=https://crossword.thehindu.com/>Crossword + Free Games</a>
</li>
</ul>
</li>
</ul>
</div>
<div class="col-md-2 col-sm-2 col-12">
<ul class="footer-list">
<li class="title">
<h5 class="footer-top-border top-border-hide-mobile"><span class="footer-arrow">Other Products</span></h5>
<ul class="footer-sub-list">
<li class="">
<a class="" href=https://roofandfloor.thehindu.com/>RoofandFloor</a>
</li>
<li class="">
<a class="" href=https://step.thehindu.com/>STEP</a>
</li>
<li class="">
<a class="" href=https://thehinduimages.com/>Images</a>
</li>
<li class="">
<a class="" href=https://classifieds.thehindu.com/>Classifieds</a>
</li>
<li class="">
<a class="" href=https://www.thehindu.com/publications/>Special Publications</a>
</li>
<li class="">
<a class="" href=https://www.thehindu.com/ebooks/>eBooks</a>
</li>
<li class="">
<a class="" href=https://www.thehindu.com/coupons/>The Hindu Coupons</a>
</li>
</ul>
</li>
</ul>
</div>
<div class="col-md-2 col-sm-2 col-12">
<ul class="footer-list">
<li class="title">
<h5 class="footer-top-border top-border-hide-mobile"><span class="footer-arrow">Popular Sections</span></h5>
<ul class="footer-sub-list">
<li class="">
<a class="" href=https://frontline.thehindu.com/news/>News</a>
</li>
<li class="">
<a class="" href=https://frontline.thehindu.com/columns/>Columns</a>
</li>
<li class="">
<a class="" href=https://frontline.thehindu.com/social-issues/>Social Issues</a>
</li>
<li class="">
<a class="" href=https://frontline.thehindu.com/economy/>Economy</a>
</li>
<li class="">
<a class="" href=https://frontline.thehindu.com/books/>Books</a>
</li>
<li class="">
<a class="" href=https://frontline.thehindu.com/arts-and-culture/>Arts &amp; Culture</a>
</li>
</ul>
</li>
</ul>
</div>
<div class="col-md-4 mobile-footer-pad"><h5 class="footer-top-border"><span>Trending on frontline.thehindu.com</span></h5>
<ul class="footer-menu-list">
<li class="border-full-bottom">
<a href="https://frontline.thehindu.com/arts-and-culture/india-at-75-epochal-moments-1947-madras-devadasis-prevention-of-dedication-act/article65720943.ece" class="trendLinkCls"><span class="trendTitleSpanCls"><span class="trendsubTitleSpanCLs">1947: Madras Devadasis (Prevention of Dedication) Act passed</span></span><span class="trendImage"><img src="/theme/images/fl-online/graph-arrow-icon.svg" alt="arrow-icon"></span></a>
</li>
<li class="border-full-bottom">
<a href="https://frontline.thehindu.com/the-nation/india-at-75-epochal-moments-1948-mahatma-gandhi-falls-to-assassins-bullets/article65721403.ece" class="trendLinkCls"><span class="trendTitleSpanCls"><span class="trendsubTitleSpanCLs">1948: Assassination of Mahatma Gandhi</span></span><span class="trendImage"><img src="/theme/images/fl-online/graph-arrow-icon.svg" alt="arrow-icon"></span></a>
</li>
<li class="border-full-bottom">
<a href="https://frontline.thehindu.com/cover-story/interview-ptr-palanivel-thiaga-rajan-central-banks-are-acting-like-politicians/article65467153.ece" class="trendLinkCls"><span class="trendTitleSpanCls"><span class="trendsubTitleSpanCLs">EXCLUSIVE | P.T.R. Palanivel Thiaga Rajan: ‘Central banks are acting like politicians’</span></span><span class="trendImage"><img src="/theme/images/fl-online/graph-arrow-icon.svg" alt="arrow-icon"></span></a>
</li>
<li class="border-full-bottom">
<a href="https://frontline.thehindu.com/arts-and-culture/cinema/something-is-rotten-understanding-the-bollywood-boycott-phenomenon/article65902023.ece" class="trendLinkCls"><span class="trendTitleSpanCls"><span class="trendsubTitleSpanCLs">Something is rotten: Understanding the Bollywood boycott phenomenon</span></span><span class="trendImage"><img src="/theme/images/fl-online/graph-arrow-icon.svg" alt="arrow-icon"></span></a>
</li>
<li class="border-full-bottom">
<a href="https://frontline.thehindu.com/dispatches/india-ranks-at-the-bottom-in-a-list-180-countries-in-the-2022-environmental-performance-index/article65497256.ece" class="trendLinkCls"><span class="trendTitleSpanCls"><span class="trendsubTitleSpanCLs">India ranks at the bottom in a list of 180 countries in the 2022 Environmental Performance Index</span></span><span class="trendImage"><img src="/theme/images/fl-online/graph-arrow-icon.svg" alt="arrow-icon"></span></a>
</li>
</ul>
<h5 class="footer-top-border"><span>Trending on our Group sites</span></h5><div class="col-md-12 col-xs-12 col-sm-12 col-lg-12 ps-0 groupsite-bt">
<ul class="footer-menu-list">
<li class="border-full-bottom">
<a href="https://www.thehindu.com/news/cities/bangalore/partial-solar-eclipse-on-october-25-to-last-for-45-minutes-in-bengaluru/article66049542.ece" target="_blank">
<span class="trendTitleSpanCLs">
<span class="trendsubTitleSpanCls"> Partial solar eclipse on October 25; to last for 45 minutes in Bengaluru</span>
</span>
<span class="trendImage">
<img src="/theme/images/fl-online/graph-arrow-icon.svg" alt="arrow-icon">
</span>
</a>
</li>
<li class="border-full-bottom">
<a href="https://www.thehindu.com/news/international/rishi-sunak-set-to-become-uks-first-british-asian-prime-minister/article66051859.ece" target="_blank">
<span class="trendTitleSpanCLs">
<span class="trendsubTitleSpanCls">Rishi Sunak set to become U.K.&#039;s first British-Asian Prime Minister</span>
</span>
<span class="trendImage">
<img src="/theme/images/fl-online/graph-arrow-icon.svg" alt="arrow-icon">
</span>
</a>
</li>
<li class="border-full-bottom">
<a href="https://www.thehindubusinessline.com/markets/stocks-that-will-see-action-on-october-25-2022/article66052096.ece" target="_blank">
<span class="trendTitleSpanCLs">
<span class="trendsubTitleSpanCls">Stocks that will see action on October 25, 2022 </span>
</span>
<span class="trendImage">
<img src="/theme/images/fl-online/graph-arrow-icon.svg" alt="arrow-icon">
</span>
</a>
</li>
<li class="border-full-bottom">
<a href="https://www.thehindubusinessline.com/money-and-banking/yes-bank-q2-pat-falls-32-on-jump-in-provisions/article66045005.ece" target="_blank">
<span class="trendTitleSpanCLs">
<span class="trendsubTitleSpanCls">YES Bank Q2 PAT falls 32% on jump in provisions</span>
</span>
<span class="trendImage">
<img src="/theme/images/fl-online/graph-arrow-icon.svg" alt="arrow-icon">
</span>
</a>
</li>
<li class="border-full-bottom">
<a href="https://sportstar.thehindu.com/cricket/t20-world-cup/bangladesh-vs-netherlands-live-score-t20-world-cup-2022-ban-ned-match-scorecard-hobart/article66050401.ece" target="_blank">
<span class="trendTitleSpanCLs">
<span class="trendsubTitleSpanCls">Bangladesh vs Netherlands Highlights T20 World Cup 2022: Bangladesh beats Netherlands by 9 runs</span>
</span>
<span class="trendImage">
<img src="/theme/images/fl-online/graph-arrow-icon.svg" alt="arrow-icon">
</span>
</a>
</li>
</ul>
</div>
</div></div><div class="row pb-2"><div class="col-12"><ul class="footer-social-icon"><li><a href="https://www.facebook.com/frontlineindia/" title="Facebook"><img src="https://frontline.thehindu.com/theme/images/fl-online/footer-icon-fb.svg"></a></li><li><a href="https://twitter.com/frontline_india" title="Twitter"><img src="https://frontline.thehindu.com/theme/images/fl-online/footer-icon-tw.svg"></a></li><li><a href="https://www.instagram.com/frontline.magazine/" title="Instagram"><img src="https://frontline.thehindu.com/theme/images/fl-online/footer-icon-insta.svg"></a></li><li><a href="https://in.linkedin.com/school/the-hindu/" title="Linkedin"><img src="https://frontline.thehindu.com/theme/images/fl-online/footer-icon-linkedin.svg"></a></li><li><a href="https://www.youtube.com/channel/UCWxdhSIVMreBHJTQlVdg9lA" title="Youtube"><img src="https://frontline.thehindu.com/theme/images/fl-online/footer-icon-youtube.svg"></a></li></ul><div class="deskBottomNav"> <ol class="breadcrumb">
<li class="breadcrumb-item">
<a class="" href=https://www.thehindugroup.com/privacy.html>Privacy policy</a>
</li>
<li class="breadcrumb-item">
<a class="" href=https://frontline.thehindu.com/termsofuse/>Terms &amp; conditions</a>
</li>
</ol>
</div><div class="copyrights"><a href="mailto:flcomments@thehindu.co.in" class="comm" title="Comments to: flcomments@thehindu.co.in.">Copyright &#169; 2022, THG PUBLISHING PVT LTD. or its affiliated companies. All rights reserved.</a></div><div class="back-to-top"><p>BACK TO TOP<img class="" data-src-template="https://frontline.thehindu.com/theme/images/fl-online/back-to-top-arrow.svg" src="https://frontline.thehindu.com/theme/images/fl-online/back-to-top-arrow.svg"></p></div></div><div class="col-12"></div></div></div></footer></div><script src="https://ajax.googleapis.com/ajax/libs/jquery/1.9.0/jquery.min.js"></script><script src="https://frontline.thehindu.com/theme/js/fl-online/bootstrap.bundle.min.js"></script><script src="https://frontline.thehindu.com/theme/js/fl-online/swiper.min.js"></script><script src="https://frontline.thehindu.com/theme/js/fl-online/jplayer.playlist.min.js"></script><script src="https://frontline.thehindu.com/theme/js/fl-online/jquery.jplayer.min.js"></script><script src="https://frontline.thehindu.com/theme/js/fl-online/theme.min.js?ver=1666353694" async defer></script><script src="https://frontline.thehindu.com/theme/js/sss.min.js"></script><script src="https://frontline.thehindu.com/theme/js/main.js"></script><script src="https://frontline.thehindu.com/theme/js/esi-parser.js"></script><script src="https://frontline.thehindu.com/theme/js/thgevnt.min.js?ver=1666353694" async defer></script><script>

  document.addEventListener("DOMContentLoaded", function (event) {
      var lazyImages = [].slice.call(document.querySelectorAll("img.lazy"));var imageSizes = [80, 100, 115, 140, 170, 215, 230, 240, 300, 320, 355,385, 435, 460, 480,560, 615, 660, 730, 810, 960, 1080, 1140, 1200];if ("IntersectionObserver" in window) {
      let lazyImageObserver = new IntersectionObserver(function(entries, observer) {
        entries.forEach(function(entry) {
          if (entry.isIntersecting) {
            let lazyImage = entry.target;
            let variant = lazyImage.dataset.deviceVariant;
            let imagesrc =  lazyImage.dataset.srcTemplate;
            if(typeof imagesrc !="undefined" && imagesrc != ""){
            if(typeof variant !="undefined" && variant != ""){
            let position = 0;
            if(DevIdf.isDesktop){
              position = 1;
            }
            else if(DevIdf.isTablet){
                 position = 2;
            }
            else if(DevIdf.isMobile){
                 position = 3;
            }
            variant = variant.split("~")[position];
            var selected = Math.max.apply(null, imageSizes);
            for (var i = 0; i < imageSizes.length; i++) {
              if (lazyImage.offsetWidth <= imageSizes[i]) {
                selected = imageSizes[i];
                break;
              }
            }
             var alterRegEx = new RegExp("alternates\/[a-z0-9_]*", "ig");
             imagesrc = imagesrc.replace(alterRegEx,"alternates/"+variant + "_" + selected);
            
             lazyImage.src = imagesrc;
            }
            else{
              lazyImage.src = imagesrc;
            }
            }
            lazyImage.classList.remove("lazy");
            lazyImageObserver.unobserve(lazyImage);
          }
        });
      });
  
      lazyImages.forEach(function(lazyImage) {
        lazyImageObserver.observe(lazyImage);
      });
    } else {
          lazyImages.forEach(function(lazyImage) {
         let variant = lazyImage.dataset.deviceVariant;
            let imagesrc =  lazyImage.dataset.srcTemplate;
            if(typeof imagesrc !="undefined" && imagesrc != ""){
            if(typeof variant !="undefined" && variant != ""){
            let position = 0;
            if(DevIdf.isDesktop){
              position = 1;
            }
            else if(DevIdf.isTablet){
                 position = 2;
            }
            else if(DevIdf.isMobile){
                 position = 3;
            }
            variant = variant.split("~")[position];
            var selected = Math.max.apply(null, imageSizes);
            for (var i = 0; i < imageSizes.length; i++) {
              if (lazyImage.offsetWidth <= imageSizes[i]) {
                selected = imageSizes[i];
                break;
              }
            }
             var alterRegEx = new RegExp("alternates\/[a-z0-9_]*", "ig");
             imagesrc = imagesrc.replace(alterRegEx,"alternates/"+variant + "_" + selected);
            
             lazyImage.src = imagesrc;
            }
            else{
              lazyImage.src = imagesrc;
            }
            }
            lazyImage.classList.remove("lazy");
       });
    }});
   
  </script><script>
$( document ).ready(function() {
$(window).scroll(function() {
  
    var navht = $('nav#navbar_top').height()+40;
    var w = $(window).width();
    var h = $(window).height();

    if ($(window).scrollTop() <= $('.articlepage .artConPage').position().top) {
    $('.shareicon-article').css('top', '0px');
    } else if ($(window).scrollTop() > $('.articlepage .artConPage .scrollend').position().top) {
    $('.shareicon-article').css('top', ($('.articlepage .artConPage .scrollend').position().top - (navht * 14)) + 'px');
    } else {
    $('.shareicon-article').css('top', ($(window).scrollTop() - (navht * 3)) + 'px');
    }

  });

});
</script><script type="text/javascript">
      var _paq = window._paq || [];
      /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
      _paq.push(['trackPageView']);
      _paq.push(['enableLinkTracking']);
      (function() {
        _paq.push(['setTrackerUrl', '//matomo.thehindu.com/matomo.php']);
        _paq.push(['setSiteId', '4']);
        var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
        g.type='text/javascript'; g.async=true; g.defer=true; g.src='//matomo.thehindu.com/matomo.js'; s.parentNode.insertBefore(g,s);
      })();
    </script><script>
    tp.push(['init', function() {
      if (!tp.pianoId.isUserValid()) loadScript("https://accounts.google.com/gsi/client")
    }])
  </script><div id="g_id_onload" data-client_id="123036381837-pvm923k0juvf1g7sk4me0u8oga9tnd47.apps.googleusercontent.com" data-callback="handleGoogleSignIn" data-skip_prompt_cookie="__utp" data-ux_mode="popup" data-moment_callback="logMomentNotification" data-auto_prompt="false"></div><style>
    .gsiOverlay {
        position: fixed;
        top: 0;
        background-color: #000;
        opacity: .65;
        width: 100%;
        height: 100%;
        z-index: 9998;
        cursor: auto;
        left: 0;
        display: none;
    }
  </style><div id="gsi_overlay" class="gsiOverlay"></div><script>
    const gsi_container = document.getElementById("g_id_onload")
    const auth_ep = "https://madhyama.thehindu.com/api/login/social";
    const response_ep = "https://madhyama.thehindu.com/api/login/social/code"
    handleResponseUrl()

    function logMomentNotification(v) {
      const gsi_overlay = document.getElementById("gsi_overlay")
      if(v.g == 'display' && v.h === true) gsi_overlay.style.display = "block"
      else gsi_overlay.style.display = "none"
    }

    function loginCallback(res) {
      handleGoogleSignIn()
    }

    function handleGoogleSignIn() {
      console.log('handleGoogleSignIn');
      const clean_url = cleanArticleUrl();
      const options = {
        method: "POST",
        headers: getHeaders(),
        body: JSON.stringify({
          "article_url": clean_url,
          "pub_id": "FL",
        })
      };

      fetch(auth_ep, options)
      .then(function(res) {
        if (!res.ok) throw new Error(res.statusText)
        return res.json()
      })
      .then(function(res) {
        if (res.uri) window.location.replace(res.uri)
        else console.log("Error: ", res)
      })
      .catch(err => console.error(err));
    }

    function cleanArticleUrl() {
      const params_to_remove = ["utm_source", "utm_medium", "utm_campaign", "utm_term", "utm_content"]

      const url_obj = new URL(`${window.location.href}`)
      url_obj.searchParams.forEach((v, k) =>
        {if (params_to_remove.includes(k)) url_obj.searchParams.delete(k)}
      )

      return url_obj.toString()
    }

    function handleResponseUrl() {
      const url_obj = new URL(window.location.href)
      const response_id = url_obj.searchParams.get("response_id")
      const redirect_uri = url_obj.searchParams.get("internal_redirect_uri")
      if (!response_id || !redirect_uri) {
        gsi_container.setAttribute('data-auto_prompt', "true")
        return
      }

      const options = {
        method: 'POST',
        headers: getHeaders(),
        body: JSON.stringify({
            "response_id": response_id,
            "pub_id": "FL"
        })
      }

      fetch(response_ep, options)
      .then(function(res) {
        if (!res.ok) throw new Error(res.statusText)
        return res.json()
      })
      .then(function(res) {
        console.log(res)
        // return if response is not ok OR no access token is present
        if (!res.status === "ok" || res.access_token.trim() === "") return
        if(window.tp.pianoId)
          tp.push(['init', function() {
            tp.pianoId.loginByToken(res.access_token)
            window.location.replace(res.redirect_uri)
          }])
        else window.location.replace(res.redirect_uri)
      })
      .catch(err => console.error("Error: ", err));
    }

    function getHeaders() {
      return {
        "Accept": "application/json, text/plain, */*",
        "Authorization": "Basic dGhlaGluZHU6a251cl9DSC1BNVBZVSU4Vw==",
        "Content-Type": "application/json",
      }
    }

  </script><script defer src="https://static.cloudflareinsights.com/beacon.min.js/v652eace1692a40cfa3763df669d7439c1639079717194" integrity="sha512-Gi7xpJR8tSkrpF7aordPZQlW2DLtzUlZcumS8dMQjwDHEnw9I7ZLyiOj/6tZStRBGtGgN6ceN6cMH8z7etPGlw==" data-cf-beacon='{"rayId":"75fe7c5b79599c31","token":"eaed15cee0874f9fad025889fee44b63","version":"2022.10.3","si":100}' crossorigin="anonymous"></script>
</body></html>